Install PostgreSQL 9.4+

Arvados requires at least version 9.4 of PostgreSQL.

CentOS 7

Note:

On CentOS 7 and RHEL 7, these packages require a more recent version from Software Collections. The Software Collection will be installed automatically as long as Software Collections are enabled on your system.

To enable Software Collections on CentOS, run:

~$ sudo yum install centos-release-scl scl-utils

To enable Software Collections on RHEL:

~$ sudo yum-config-manager --enable rhel-server-rhscl-7-rpms

See also section 2.1 of Red Hat’s Installation chapter .

  1. Install PostgreSQL
    # yum install rh-postgresql12 rh-postgresql12-postgresql-contrib
    ~$ scl enable rh-postgresql12 bash
  2. Initialize the database
    # postgresql-setup initdb
  3. Configure the database to accept password connections
    # sed -ri -e 's/^(host +all +all +(127\.0\.0\.1\/32|::1\/128) +)ident$/\1md5/' /var/lib/pgsql/data/pg_hba.conf
  4. Configure the database to launch at boot and start now
    # systemctl enable --now rh-postgresql12-postgresql

Debian or Ubuntu

Debian 10 (Buster) and Ubuntu 16.04 (Xenial) and later versions include a sufficiently recent version of Postgres.

  1. Install PostgreSQL
    # apt-get --no-install-recommends install postgresql postgresql-contrib
  2. Configure the database to launch at boot and start now
    # systemctl enable --now postgresql

Previous: Test Slurm dispatch Next: Install Ruby and Bundler

The content of this documentation is licensed under the Creative Commons Attribution-Share Alike 3.0 United States licence.
Code samples in this documentation are licensed under the Apache License, Version 2.0.